Bunch of noises in the audio data

Post Reply
juanyi
Posts: 17
Joined: Thu Jan 28, 2021 7:38 am

I was trying out some simple spelling to the quickfeather. The audio data collected in DCL contains a lot of noises, did anybody know how to filter/remove the noises or configure/fine-tune the onboard Infineon mic? The model failed miserably with this kind of data.
Image
Attachments
Noises.png
Noises.png (128.7 KiB) Viewed 325 times
shimemar
Posts: 3
Joined: Mon Feb 08, 2021 8:11 am

Hello

I also confirmed, but the situation is the same.
It's the same even if I attach a microphone to the outside, so I'm giving up using it now.
juanyi
Posts: 17
Joined: Thu Jan 28, 2021 7:38 am

shimemar wrote: Tue Feb 09, 2021 11:51 pm Hello

I also confirmed, but the situation is the same.
It's the same even if I attach a microphone to the outside, so I'm giving up using it now.
So you attach a 3rd party microphone?
I'm hoping somebody from QuickLogic to get us through this but still no reply from them, I wonder do they look at this forum or not. Anybody else having the same issue here?
gpcm
Posts: 4
Joined: Thu Jan 21, 2021 9:27 pm

Same issue here!
anthony-ql
Posts: 49
Joined: Thu Jun 04, 2020 1:26 am

Please let us know which QORS_SDK version you used for collecting audio data. The latest tag version 1.7.0 has improvement to eliminate the noises seen in some systems. Link https://github.com/QuickLogic-Corp/qorc ... tag/v1.7.0
juanyi
Posts: 17
Joined: Thu Jan 28, 2021 7:38 am

I was using v1.5.0 before. Same noise issue even I tried v1.7.0. Could it be some fine-tuning or pre-processing needed for the MIC?
gpcm
Posts: 4
Joined: Thu Jan 21, 2021 9:27 pm

I am using version 1.8
anthony-ql
Posts: 49
Joined: Thu Jun 04, 2020 1:26 am

The issue is reported to internal team. We are working on validating the issue and will look for solution. Stay tune.
jmoore
Posts: 12
Joined: Fri Oct 16, 2020 4:52 pm
Location: Portland

This should be fixed in the latest DCL release (2020.10.6, or you may see an update for 2020.10.7 come Monday the 8th.)
juanyi
Posts: 17
Joined: Thu Jan 28, 2021 7:38 am

Yes, thanks for the remedy! It audio data is clean now.
Post Reply