QuickFeather first install of driver for Windows 10

Post Reply
bobbobber
Posts: 5
Joined: Fri May 15, 2020 8:31 am
Location: London

After powering up the QuickFeather board and pressing the RESET button, Windows installed the drivers, but I found that on several machines the device driver had timed out, with an error code 10.

The fix I found was to either press the RESET button again or power cycle the board. This was only required when first installing the drivers on a new PC.

Otherwise, the board worked as expected out of the box.
anthony-ql
Posts: 49
Joined: Thu Jun 04, 2020 1:26 am

Thank you for the feedback. UserGuide is updated with the information with regard to Windows 10 device driver may need reboot.
rsato
Posts: 11
Joined: Fri May 15, 2020 6:03 am
Location: Japan

Successfully done on my Windows10 laptop.

Note.
- Appears with COM4 port on my laptop
- SW Version ; OP2-QuickFeather-simple-app as default
Attachments
QF init.png
QF init.png (21.69 KiB) Viewed 1203 times
Fcozzani
Posts: 1
Joined: Mon Jan 11, 2021 9:03 pm

I try to connect and presso reset but my windows 10 say not driver installed. I try again and again like in guide but no driver selected.

In an other pc with windows 10 it work! Have you right driver to download?

Tks

Federico
anthony-ql
Posts: 49
Joined: Thu Jun 04, 2020 1:26 am

Thanks for the feedback. Are the Windows 10 version the same between the 2 machines? We have tested the board and drivers with Win 10 Pro.
MaxPower
Posts: 5
Joined: Sun Jan 24, 2021 6:29 pm

I have the same problem. On Win10, it does not find the driver and displays error code 10. Because of this error, I cannot follow the example from your video https://www.youtube.com/watch?v=OW4wNNL ... ackster.io.

When trying to run the command from the example: python tinyfpga-programmer-gui.py --port COM4 --m4 quickfeather-simple-stream-data-collection.bin --mode m4

Outputs:
CLI mode
ports = ['COM4 (QuickFeather)'] 1
Using port COM4 (QuickFeather)
Traceback (most recent call last):
File "D: \ QuickLogic \ TinyFPGA-Programmer-Application \ tinyfpga-programmer-gui.py", line 622, in <module>
adapter.program (m4appname, progress, "Programming m4 application with", args.checkrev, args.update)
File "D: \ QuickLogic \ TinyFPGA-Programmer-Application \ tinyfpga-programmer-gui.py", line 144, in program
with serial.Serial (self.port [0], 115200, timeout = 60, writeTimeout = 60) as ser:
File "C: \ Users \ maxpower \ AppData \ Local \ Programs \ Python \ Python39 \ lib \ site-packages \ serial \ serialwin32.py", line 33, in _
_init__
super (Serial, self) .__ init __ (* args, ** kwargs)
File "C: \ Users \ maxpower \ AppData \ Local \ Programs \ Python \ Python39 \ lib \ site-packages \ serial \ serialutil.py", line 244, in _
_init__
self.open ()
File "C: \ Users \ maxpower \ AppData \ Local \ Programs \ Python \ Python39 \ lib \ site-packages \ serial \ serialwin32.py", line 64, in o
pen
raise SerialException ("could not open port {! r}: {! r}". format (self.portstr, ctypes.WinError ()))
serial.serialutil.SerialException: could not open port 'COM4': FileNotFoundError (2, 'The specified file cannot be found.',
None, 2)

Is there a solution to this problem?
ralphjy
Posts: 4
Joined: Wed Jan 27, 2021 4:26 am

Has anyone figured out how to fix this?

I have only been able to get the Serial port to work on one of three Win10 Pro computers. And that took me several tries before it worked.

The port always shows up, but it fails to start.
anthony-ql
Posts: 49
Joined: Thu Jun 04, 2020 1:26 am

@ ralphjy, thanks for your feeback. Can you let me know the Win 10 build version for the the PCs. The information can be found under Settings -> Home -> About -> Windows Specification.
ralphjy
Posts: 4
Joined: Wed Jan 27, 2021 4:26 am

All 3 computers are running Windows 10 Pro. Two are Version 2004, build 19041.804. One is Version 1909, 18363.1198.

One of the Version 2004 computers is working, but it took several tries before it would work. The standard serial device driver is quite old. This board probably needs a new driver.
anthony-ql
Posts: 49
Joined: Thu Jun 04, 2020 1:26 am

Thanks for the update information. I will check with others and see if there is solution to your issue.
Post Reply