Helloworld error

Post Reply
Posts: 2
Joined: Wed Jun 17, 2020 10:39 am

While installing zephyr SDK using the command
./zephyr-sdk-0.11.2-setup.run -- -d ~/zephyr-sdk-0.11.2
I get below error many times while it instal arm packages
[|] Installing arm64 tools...sleep: cannot read realtime clock: Invalid argument

But finally it says the installation is through.

Later, after completing all remaining the steps of setup, when I tried compiling HelloWorld sample, it gives error:

Assertion failed: The detected dtc version is unsupported.

The version was found to be 0
But the minimum supported version is 1.4.6
See https://docs.zephyrproject.org/latest/getting_started/
for how to use the SDK's dtc alongside a custom toolchain.
Posts: 2
Joined: Wed Jun 17, 2020 10:39 am

Forgot to mention, I'm using Windows Ubuntu App. Ubuntu 20.04 LTS.

I have found a solution for arm errors here:
https://askubuntu.com/questions/1230252 ... -20-04-wsl

As suggested I have tried below procedure. I did it on a fresh system. After doing this when I installed SDK it didn't give any errors.

Code: Select all

wget https://launchpad.net/~rafaeldtinoco/+archive/ubuntu/lp1871129/+files/libc6_2.31-0ubuntu8+lp1871129~1_amd64.deb
sudo dpkg --install libc6_2.31-0ubuntu8+lp1871129~1_amd64.deb
sudo apt-mark hold libc6
sudo apt --fix-broken install
sudo apt full-upgrade
Proceeded further to complete other steps as per the document. HellowWorld is compiling on this system!
Post Reply