First impressions on FPGA toolchain

Posts: 3
Joined: Tue May 19, 2020 5:48 am

Currently, we have not created the Symbiflow installer on Debian linux.
Posts: 12
Joined: Wed May 27, 2020 6:33 am

kakkamies wrote: Tue Jun 16, 2020 10:23 pm I downloaded the installer and tried to install it on a Debian running under Linux Subsystem for Windows.
The installer fetches stuff from the web and part of it fails.

Code: Select all

Collecting package metadata (current_repodata.json): failed

CondaHTTPError: HTTP 000 CONNECTION FAILED for url <>
Elapsed: -
An HTTP error occurred when trying to retrieve this URL.
HTTP errors are often intermittent, and a simple retry will get you on your way.
This could have been a temporary issue on server. If this still persists, follow these manual steps and check.
I could able to run the example design.

export INSTALL_DIR=<install path>
wget ... -O
bash -b -p $INSTALL_DIR/conda && rm
source "$INSTALL_DIR/conda/etc/profile.d/"
conda update -y -q conda
wget -qO- ... download=1 | tar -xJ -C $INSTALL_DIR
conda install -c quicklogic-corp yosys
conda install -c quicklogic-corp yosys-plugins
conda install -y -c antmicro/label/ql vtr
conda install -y make lxml simplejson intervaltree git pip
conda activate
pip install python-constraint
pip install git+
pip install git+
pip install git+ ... fasm-utils

export PATH="$INSTALL_DIR/install/bin:$INSTALL_DIR/install/bin/python:$PATH"
source $INSTALL_DIR/conda/etc/profile.d/
cd install/tests/counter_16bit
ql_symbiflow -compile -d ql-eos-s3 -P pd64 -v counter_16bit.v -t top -p counter_16bit.pcf
Posts: 3
Joined: Tue Jun 16, 2020 10:07 pm

Thank you for the reply.
The problem still exist and following the step-by-step instruction it occurs at

Code: Select all

conda update -y -q conda
Web access on the machine seems to be fine since I can download the < ... odata.json> using wget.
I even tried switching the distribution to Ubuntu. This did not have an effect.

Edit: This problem has to do with me running Linux in Win10 WSL. Attempted the installer again on a spare computer with non-virtual Debian 10 this time with success.
Edit2: after updating to WLS2 and reinstalling the distro it works.
Posts: 12
Joined: Wed May 27, 2020 6:33 am

Good to hear that you were able to proceed. So the problem seems to be WLS2. Will note that.
Post Reply